Jannewap Blog- Artikel-Anzeigeproblem im Internet Explorer endlich gefixt

Ich kam um’s verrecken nicht drauf! Meine Seite wurde immer richtig und sauber angezeigt. Das hat sich ffenbar vor einiger Zeit geändert. Im Internet Explorer 6 & und im IE8 wurde die Sidebar meines Blogs erst unter den Kommentaren angedockt statt neben dem Container mit dem Hauptinhalt, wenn ich auf der Seite eines Einzelartikels war.

Ich hab mich durch’s .css gewühlt, die einzelnen zu ladenen .php’n gesichtet aber nichts gravierendes gefunden. Mir egal! Sollen die Internet Explorer User halt auf nen vernünftigen Browser umsteigen. In den anderen Browsern wurde die Seite schließlich sauber angezeigt!?!?

Bevor ist soweit war, zu resignieren hab ich mich noch einmal durch die single.php gewurschtelt. Und ich hab das Problem gefunden. Ich war das Rind und habe einen der glattesten Anfängerfehler begangen, die man nur machen kann. Alle von mir getesteten Browser haben meinen Fehler gefunden aber den Seitenaufbau richtig interpretiert und den Tag geschlossen. Dem blauen E war das völlig egal- wie in einer Behörde: “Ich habe meine Vorschriften!” hat der einfach das dargestellt, was ihm gesagt wurde.

html-Regel Nummer 1: Wenn Du einen Tag eröffnest, sollst Du ihn auch wieder schließen!

Ich habe diese banale Grundregel einfach nicht beachtet. Mach einen span-Befehl auf, dann musst Du ihn auch wieder schließen!:

Darauf muss man ja nu auch erstma’ kommen. Ich danke aber allen Unterstützern, die mich mit Tipps und Referenz-Quelltexten während meiner Fehlersuche unterstützt haben!

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Top